iPad Application Update for Kite Student Portal

To support iOS 15, the Kite® Student Portal iPad application must be updated to version 8.0.1 prior to testing. You are required to update the app if you plan to update the testing device to iOS 15.

The application will update automatically unless this feature has been disabled on the device.

Please share this message with your colleagues and show them how to subscribe to DLM Test Updates (from this page). Thank you.

Best,

DLM Staff

Date
August 20, 2021