KITE Client for iPad updated

An updated release of the KITE Client for iPad is now available for use with DLM® assessments. This release improves the security of the testing environment and resolves several error messages. If Automatic Updates are enabled on your iPad, no action is required. If Automatic Updates are not enabled on your iPad, visit the the App Store on your iPad to download the updated client.

This update is recommended but is not required. iPad users may update at their convenience. Users of other KITE Clients (Windows, Mac, Chromebook) are not required to update.

Date: 
Friday, January 2, 2015

MENU